Skip navigation
All Places > Product Forum > Hypervisors > Blog

Hypervisors

5 posts

Introduced in Turbonomic v5.0 is the ability to add your Java Application Servers into Turbonomic by leveraging for Red Hat JBoss, the managed domain – domain controller or the standalone server.  This methodology provides more information of heap, thread pool utilization, and average servlet response times - information used to drive decisions to resize heap or the thread pool, or clone to scale out horizontally.

 

This article describes some tips on adding a JBoss managed domain – domain controller or standalone server as a target, and terminology used.

Looking for information on Oracle WebLogic or IBM Websphere support introduced in Turbonomic 5.1? Check out: Turbo Tip: Application Control Module and adding Oracle WebLogic as a Target and Turbo Tip: Application Control Module and adding Oracle WebLogic as a Target

 

Prerequisites

License key for Application Control Module or Application Edition is required and Turbonomic v5.0 or higher to see Red Hat JBoss as a target.

 

Overview: Red Hat JBoss

Two different configurations

          Managed Domain – domain controller

          Standalone Server

 

Managed Domain will be Auto-detected and requires HTML API port and user/password.  Ports are obtained from xml configuration files:

          Managed Domain
               <Jboss folder>/domain/configuration/host.xml
          Standalone Server
               <Jboss folder>/standalone/configuration/standalone.xml

 

JBoss Target Configuration

From within Turbonomic, Navigate to Admin --> Target Configuration --> Application Server and select JBoss to input the necessary credentials:

 

 

JBoss – Port Info

Look for the Http-interface in the management section in host.xml.  Default is 9990.

Note: The interface must be made accessible from remote location:  the inet-address for management interface must be set on 0.0.0.0.

 

JBoss Threads

The thread commodity exists only if the HTTP connector defines a thread pool.  To make sure, look for the executor attribute in the HTTP connector, domain.xml:

 

<subsystem xmlns="urn:jboss:domain:web:1.4" …>

          <connector name="http" protocol="HTTP/1.1” executor="JBossWeb…

 

<subsystem xmlns="urn:jboss:domain:threads:1.1">

                <unbounded-queue-thread-pool name="JBossWeb">

 

                    <max-threads count="120"/>

 

JBoss – Naming Convention

There are three parts in the name of a discovered JBoss AS instance:

-        

  • IP address

 

  • Controller name/STANDALONE

          From host.xml:
           <?xml version='1.0' encoding='UTF-8'?>

                                <host name="master" …>

                                                <management>

 

  • Server name

          <servers>

               <server name="server-one" …>

 

 

-          Standalone installation:  the host name

Hello all,

 

I recently found this product and I am trying to test it out for my environment. I got the server stood up fine and imported the license file but I am having a hard time targeting any of my Hyper-V hosts in my environment.

 

Troubleshooting information:

App Server for VM Turbo: 10.68.60.x

Host network network: 10.60.1.x

iSCSINET network for hosts: 192.168.50.x

Hyper-V Manager for hosts: Ver 6.3.9600.16384

Hosts are in a cluster

I can ping between the networks

I can view the VMTURBO app server from a device on the 10.68.60.x network.

I have checked inbound firewall rules for WMI and opened 135 traffic on the host.

 

Under Target configuration

I select Hypervisor / Hypver-V

Host name or IP address: I have tried both the host network address and the host name

Full Domain Name: I have used my: domain.companyname.com and I have tried my short name for my domain: domain

Username: I have tried: domain\username and: domain.companyname.com\username

Password: My password


I get this error:

 

 

I am obviously able to RDP into the any of the host with my domain\username credentials and manage them.

 

Key note in troubleshooting: If I go to a server on the 10.68.60.x network (2012R2 domain controller) add go to server manager and add the host to the all servers list and try to login I have issues with my credentials too. I can enter the IP it resolves DNS and I get this error:

 

Not sure if this is related.

 

Thoughts?

 

Thanks for your help,

This morning around 10 AM, I was asked to join a "HURT" bridge due to an application product that experienced mainframe cpu response time issues. This application product is virtualized in our Cisco UCS infrastructure running VMware vSphere 5.0. When I joined the call I asked for a brief overview. The duty manager provided the following, "yesterday around 1700 a drop in cpu "meaning mainframe com's" occurred. The duty manager wanted to know if there was any impacts, problems, errors within UCS and VMware infrastructure.

 

Now that you have a reference point, as IT managers we get these calls "a lot", but mine seem to be more in the 2 AM to 4 AM time slot. I guess I got luck this morning.

 

So, I asked the 15 or so folks on the trouble bridge what product was impacted and can someone provide me VM names that were experiencing these time outs. The team quickly sent via IM a list of VM names. While they were sending me those VM names, I was establishing connectivity with our VMTurbo Operations Manager web console. I logged into VMT and immediately went to the supply chain tab... I wanted to start looking at a high-level birds-eye view if there was a problem in my area of responsibility (which is all Cisco UCS and VMware for the company). I copied one of the VMs in question and searched by selecting the "virtual machine" within the supply chain navigation section. I quickly identify what VMware ESXi host the VM was running on and what the "current" utilization was. This helped me to determine what Cisco UCS POD this VM was running in (as we have 80 UCS domains running within our data center's). Meanwhile, the duty manager was commenting that Tivoli and Indicative where seeing errors coming from other Cisco UCS domains "thermal errors in POD35, error accessing shared storage in POD48". I quickly reported back on the bridge that these errors did not contribute to the issues at hand. I also reported that POD25 was the UCS domain where all of the VMs were hosted. I went back to June 26 @ 1700 within VMT and looked at what the power and cooling utilization was and reported this was normal. All network northbound Ethernet/FC and southbound DCE bandwidth was less than 2% utilization. As I reported back all of the vital UCS and VMware infrastructure was normal during the time period in question. We team started looking at other areas (F5 load balancers and mainframe comms). The "HURT" bridge closed down within the hour (which was a first, as these things tend to drag on and on...).

 

In summary - I have used VMTurbo for several of these trouble calls and I'm able to quickly navigate through all of the confusion "on the bridge" and drill down into the "data" or the facts. VMTurbo has proven itself again this morning, that its not just a VM capacity management tool, but the virtualization infrastructure tool you must have in your IT virtualization toolbox!

This article will help with the following questions:

- How do I deploy the VMturbo appliance if I am not running DHCP?

-The VMTurbo appliance 'hangs' after a message ' NET: Registered protocol family 17 ' and I cannot access it

- How do I configure a static IP address for my VMTurbo appliance ?

 

First you need to deploy the Xen build of the VMTurbo virtual machine using the standard steps described in the deployment guide.

If DHCP is enabled on the network, the VMTurbo virtual machine will boot and you can change the ip address to a static IP from the console using the ipsetup/ipsetup credentials. In this case, you do not need the rest of the steps in this article.

If the DHCP is not enabled on your network, you need to deactivate the virtual network interface of the VMTurbo virtual machine during the boot process by clicking on the Deactivate button in the screen shown below:

screen-capture-8.png

You can confirm that the interface was deactivated by checking the Active field in the screen shown below:

screen-capture-9.png

And by checking the log window for the successful completion of the action:

screen-capture-10.png

Now, please wait for the login prompt to appear in the console window, as shown below:

screen-capture-11.png

And active the virtual network interface again, so that we can configure it:

screen-capture-12.png

You can confirm that the activation was successful by checking the Active field or the Logs tab for the virtual machine:

screen-capture-13.png

Now you can navigate back to the console window and log into the virtual machine as ipsetup/ipsetup:

screen-capture-14.png

And to configure the static ip address:

screen-capture-15.png

Finally hit enter on the OK selection in the console (you can navigate between the fields using the tab key) and the ip address configuration will be applied.

After this point, you will be able to access the VMTurbo web user interface by navigating to the configured ip address using your browser.

Symptoms

 

When installing XenTools inside the VMTurbo Operations Manager server for XenServer the following error is returned:

       Fatal Error: Failed to determine Linux distribution and version.

 

Cause

 

The default installation script for XenTools is unaware of the Linux distribution and version used for the VMTurbo OpsMan server.

 

Resolution

 

Steps to install XenTools:

  1. Use XenCenter to load the xs-tools.iso into the OpsMan VM:

    xencenter.jpg
  2. Log into the Ops Mgr Server and mount the ISO file by issuing the following command:
    # mount /dev/xvdd /mnt
  3. Run the following command to launch the XenTools install:
    # /mnt/Linux/install.sh -d sles -m 11

    Note: The distribution name (openSUSE) and version (11) are passed as parameters to install.sh.  While the VMTurbo Ops Manager server actually runs openSUSE version 12.3, XenServer will only recognize openSUSE releases up to version 11, therefore 11 must be specified for the version argument.
  4. Press ‘y’ at the following prompt:

    prompt.jpg
  5. Once the installation completes, reboot the appliance.

 

More Information

This article applies to VMTurbo Operations Manager 3.3 and earlier.