Retirement of openSUSE Support

Document created by Gregory Dunn Expert on Jan 25, 2017Last modified by yoni.friedman on Feb 1, 2017
Version 4Show Document
  • View in full screen mode

Turbonomic ships as a pre-configured virtual machine image.  For the last several years, that VM ran the openSUSE distribution of Linux, specifically openSUSE 13.2.  Starting with release 5.7, Turbonomic has begun a process to migrate away from openSUSE 13.2 and to base future releases on CentOS, initially CentOS 7.

 

NOTE: This article discusses changes to our delivery of the openSUSE OVA. Turbonomic also delivers a version of the Turbonomic server that you can deploy on a RHEL platform. This article does not apply to that RHEL delivery.

 

Why is Turbonomic making this change?

Official support for openSUSE 13.2 ended on January 17, 2017.  As a result, the openSUSE project will no longer issue patches for that version, including patches for security issues.

 

Why not migrate to a new version of openSUSE?

The openSUSE project does not accept patches from other Linux distributions. Instead, it re-implements those patches so that any given openSUSE release continues to ship with fixed versions of related software, with only required patches.  While this makes the given openSUSE releases more stable, it has proven to have two unfortunate effects:

  • Security patches are often delayed in arriving while the openSUSE project re-works them
  • Version numbering on openSUSE is not like version numbering for other Linux distributions – this can lead to inaccurate reports from security scanners

Security is increasingly important in the enterprise.  These limitations have led us to look for an alternative.

 

Why CentOS?

CentOS is the free version of Red Hat Linux, the most widely used Linux distribution in enterprise use today.  Migrating to CentOS positions us in the mainstream of Linux enterprise development, where patches – particularly security patches – are most quickly available.

 

What does this mean to me?

You must ultimately migrate your existing Turbonomic instance to a new CentOS virtual machine.

The migration procedure first writes all the data that defines your Turbonomic instance to a file. The saved data includes user accounts, target and policy definitions, and all historical data in the SQL database.  Then the migration loads this data into the new virtual machine

The Turbonomic Installation Guide (available here) documents migration, and you can always ask Turbonomic Support to guide you through the process (send an email to support@turbonomic.com).

 

What's the timeline?  When do I have to do this?

The sooner you migrate to a CentOS VM the better, but this is not an emergency.  Note that Turbonomic endeavors to make this migration process as simple as possible.

To migrate from a source VM to a new VM, both VMs must be running the same version of Turbonomic. For example, if you want to migrate version 5.7 from an openSUSE VM to a CentOS VM, then the both VMs must be running Turbonomic version 5.7.

As outlined in the roadmap below, Turbonomic will ship parallel versions of the software for a number of releases, giving you the opportunity to schedule your migration when it makes sense for your organization. According to this plan, we will release two full versions before last version that enables a migration to a CentOS VM.

 

What's the roadmap?

We plan to deliver Turbonomic updates as follows. Please note that this is an estimated roadmap, and details can change.

 

5.7 GA

The first Turbonomic release that will exist in parallel form for both openSUSE 13.2 and CentOS systems.

At the time of initial release, 5.7 will be available only as an offline update, not as an online update or as a deployable VM. Users who install this offline update will be able to migrate to the 5.7 version of the CentOS deliverable when it becomes available.

 

5.7 GA – Online Update and VMware Deployable

The first available release of Turbonomic on a deployable VM built with CentOS. This will be an OVA for deployment in VMware environments.

This release includes the online update to 5.7, as well as a CentOS VM. Customers who run Turbonomic on VMware hypervisors can migrate to this VM.

 

NOTE: Releasing the 5.7 OVA at this time breaks with our n/n-1 delivery model – n/n-1 means that we deliver updates to version n, and we deliver OVAs for version n-1. We will return to n/n-1 for version 5.8.

 

5.7 GA – Other Deployables

A release of Turbonomic on CentOS VMs for the full set of hypervisor technologies that we can deploy to:

  • VMware Systems
  • Citrix XenServer
  • Microsoft Hyper-V
  • RHEV

All of our customers can migrate to this release.

After this date, the CentOS deployables replace the openSUSE deployables. We will no longer publish openSUSE deployables.

 

5.7.x

For all of the 5.7 point releases, we will provide upgrades in both openSUSE and CentOS.  openSUSE users can continue to apply upgrades until they are ready to migrate.

 

5.8 GA

Release CentOS deliverables for 5.7 and 5.8, plus online and offline updates to 5.8 that run on openSUSE and CentOS.

For this version:

  • An online update is to version 5.8
  • Offline updates can be to 5.7 or to 5.8
  • You can migrate to 5.7 or to 5.8 CentOS VMs

Customers using openSUSE can continue to apply upgrades and updates until they are ready to migrate.

 

5.9 GA

Release CentOS deliverables for 5.8, plus online and offline updates to 5.9 that run on openSUSE and CentOS.

For this release we return to the n-1/n delivery model, where the available deployable VM is version n-1, and the GA update is for version n. We release the CentOS deployable VM for version 5.8, the online update is for 5.9, and the offline updates are for 5.8 and 5.9.  We continue to publish online and offline updates for both openSUSE and CentOS.

This is the final Turbonomic release that will support openSUSE.

 

5.10 Onwards

Release CentOS deliverables for 5.9, and release online and offline updates to 5.10 that run on CentOS, only.

All existing Turbonomic instances must have migrated to CentOS in order to run version 5.10. If you are still running 5.9 on openSUSE, then you must migrate to CentOS 5.9 before updating to 5.10.

12 people found this helpful

Attachments

    Outcomes