cgrossmeier

NULL POINTER ERROR in vCenter Validation

Discussion created by cgrossmeier on Sep 30, 2019
Latest reply on Oct 1, 2019 by cgrossmeier

Deployed Turbonomics for the first time to evaluate the automation functionality.  The appliance deployed and started without issue.  When adding a vCenter resource, we keep getting an error.  

 

We start with a quick discovery, select our existing vCetner, and add vCenter Admin credentials. The appliances starts its scan and it begins inventorying VM's and resources until it hits an error.  The same error occurs every 10 minutes and we never get data into the appliance.

 

Discovery failed

Sep 30, 9:37 AM 
vCenter:172.##.##.##
Error occurred executing operation 421 for target 172.##.##.## in thread sdk-op-421, Cause: Failed to convert vm-345 from VirtualMachine to: VIRTUAL_MACHINE: null (java.lang.NullPointerException)
Is this an internal error to the appliance or a vCetner issue?  We've tried multiple credentials for vCetner Admin with no success.  I was able to execute the CURL test command from the deployment troubleshooting docs as well and received a response without errors.  vCenter  error  null

Outcomes